Fanatec Driver 442 (Beta) for CSL, CSW and Podium WB (all wheels)



  • Thanks for your help, but I need the full FwPedalsUpdater.

  • edited June 2022

    As the issue you have is a Windows issue where I posted a link for repair, the FWPedalsUpdater.exe very likely wont help you as it seems you need to repair your Windows.

    Anyway, attached the .exe (in the zip) you want.

  • JuppJupp Member

    Damn, download disabled...

    Looks like i am late to the party, wanted to test it on my DD2.

    When can we expect a new download?

  • Thanks for the help.

    But it doesn't work at all...

    What I don't understand, why do I need new windows drivers to update the pedals? I was also able to update the wheel, base and motor without these drivers.

    Why not program it plug and play without me having to be a computer pro?

    When is a version for Mac coming?

  • edited June 2022

    No Mac version planned.

    It usually is plug and play, the issue you have is an exclusive issue only you have and from a Google search its a Windows issue.

    Follow the guideline I have linked you to repair Windows, then the Updater might work (after following the guide its best to uninstall the Fanatec Driver and re-install it again). Otherwise a Windows re-install might be required as something else with your OS-install is wrong then - but its not an issue of the Fanatec driver or updater, the updater just requires a file from a tool which your Windows does not have properly installed.

  • I’m having a new problem with my DD1 after updating the firmware that I don’t recall feeling before. When driving AWD cars, my wheel is super grainy and buzzing when accelerating. Only when accelerating in AWD cars, feels terrible and you can hear it, seems like the buzzing is directly related with throttle position, but again only in AWD cars. Any advice?

  • Hi Marcel,

    I was able to install the 440 driver and updated the Formula V2 to V44 firmware without any problems.

    This is not possible with the 442 driver. The manual update of the firmware for the V2 to V45 was also not possible and aborts with the same error.

  • sdo an update here, i had to manually copy over the plugin again, its ~200kb different size to the old one.

    I had assumed that the installer would look after it, or fanalabs would, but anyhow, manual copy fixed the telemetry again. details here

  • Actually has nothing to do with driver 442 but with FanaLab 1.64.5 as in that FanaLab Version the Telemetry for rF2 was completely re-done and therefore the new plugin is indeed needed, but anyway good catch.

  • Thanks Marcel! It now works again. Thanks for getting a fix out so soon!

  • Hi to everybody, :A question, i have just ordered one podium f1 dd1 , when i put the firmware for the first time, it's better to do with the wheel on, or only the base first and after upgrade the firmware of the wheel??? Witch is the correct, to avoid to make a brick...::((((

    Thanks in avance

  • Marcel PfisterMarcel Pfister Member, Administrator

    we are working towards next week but want to make sure rule out update issues as good as we can and don't want to rush things

  • Marcel PfisterMarcel Pfister Member, Administrator

    We are investigating the issue and will have a look if it can be detected and solved from our end as well, but like Maurice said it seems to be an issue of Windows missing something to run the application

  • Marcel PfisterMarcel Pfister Member, Administrator

    Increase INT (Interpolation) and/or decrease FEI (Force Effect Intensity).

    The base is now able to recreate the FFB signal more accurately but this includes potentially unwanted noise coming from the game and filter setting like the mentioned above might help to dial them in.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Interesting, the firmware file v45 seems to be the issue for you with not being able to update correctly. Thank you for trying out the different possibilities.

    Just to be sure, did you try driver 440 to manually load V45?

  • Marcel - can you explain to the community how the beta and official release designations are differentiated?

    This release which includes two years of development was not released to the community for testing - it was released straight away as an official driver. Now we see that community testing has revealed issues that have led to the release being withdrawn for rework.

    I'm genuinely interested in how the internal development and testing of beta and official releases differ? I'm sure others will be too as many people on the forum have expressed hesitancy in updating drivers fearing unforeseen negative consequences.

  • I got the issue "Update Mode: Wireless Quick Release" error when I tried updating from the old (ca 430) to the 440.

    After a few tries, I attempte to (successfully) get the 336 on as a base. This allowed windows to at least see the base, fans were going at 100% though (Also tried like 8 different ports too).

    I then tried the 442, this also ran in to the same issue.

    Then I tried the 439, same thing again (will attach a screenshot)

    I am going to work my way back through the versions till I find one that works again.

  • edited June 2022

    WQR issues like this are pretty much always a hardware issue which needs a repair or exchange RMA from the technical support...

  • Marcel PfisterMarcel Pfister Member, Administrator

    When you did flash the wheel firmware using driver 440, was the base running with the new firmware or was it done with the older base firmware which is contained in 440?

    Our developer had a look at the base firmware code to see if there is a difference related to the update process. There was one new function added which might influence the update behavior, so he created a test export reverting the change. If it looks like you can't update the wheel while using you can give this base firmware a try to see if the updates then works fine.

    Before flashing this firmware you should already have updated to motor firmware!

  • Marcel PfisterMarcel Pfister Member, Administrator
    edited June 2022

    Normally I (should) name the driver threads either "Beta" or "Release Candidate". Both indicate different states or lets say levels of how confident we are with it getting put on the website as a final release.

    This thread has none of both because I forgot to add "Beta" to it. If this would be a final release driver, it would have gone to the website at the same time. Sorry for the confusion, I think Maurice took the missing Beta tag too literally and was defending the labeling even though it was not needed to defend it.

    I'm on the same page with this driver making huge changes and is impossible to declare it final or even release candidate right away and for sure is here as a beta first.

    Sorry for the confusion, I'll add the "Beta" to the title now and try to make sure I'm not forgetting it again. Also in the past I didn't really update titles when something went from beta or release candidate to final on the driver, I need to keep that in mind and update the titles accordingly in the future. For example if 443 would get here as a "Release Candidate" and later end up on the website I should rename it to "Public Release"


    I think part of the question was also what happens before driver end up here? All drivers get tested internally and with external closed beta testers before it gets uploaded here. Like said when a driver gets uploaded here it should be either beta, especially if its the first upload of the iteration or release candidate if for example hot fixes were already applied. But you are correct, no driver getting uploaded here first can /should directly be a final release driver as broader testing is always needed.

  • Sad to read all the problems, must be a big effort to solve all the problems if even possible. So many factors...

    Even though reading comments/problems regarding the same Fanatec hardware I own, I've updated all my Fanatec succesfully without a hitch.

    Running Win11 21H2. All Fanatec peripherals connected through base and then with the original USB cable (and an extension) straight from base to mobo USB 3.0 (I have no USB 2.0 ports). Pedals were obviously momentarily connected to PC via USB for the 1.34 firmware update.

  • Was it already possible to take look at this issue? Because my base is in the same state, only if I hold the power button the fan spins 100% with calibrating the QR to 45° and if I release the Power button the base turns off again, so the base don't start in bootloader mode. There also no reaction from Windows or Linux PC that a USB-device is connected. I´m already in contact with the support, but it takes a lot of time when the answer takes 6 days each time.

  • A friend of me has the same issue with his DD2.

    Please try to remove the wheel and than try to put the base in bootloader mode. On his base the auto flash starts but the base doesn't get fixed.

    His base is in the RMA process but in my opinion it is worth trying.

  • edited June 2022

    And that´s exaclty where the problem is, it doesn´t get that far. Like I wrote before, if I hold the button the fan starts and the axis turn to 90° to the right, as soon as I release the button the base turn off with the normal pop off the motor.

  • When the base is in this state I fear it's not possible to resurrect it again, it's most likely dead and all you can do is wait for the support...

  • Marcel PfisterMarcel Pfister Member, Administrator

    I saw the video you've send to support and agree with Maurice that this is a state where only support can repair the base. The communication between main controller and WQR module seems defect.

  • Thanks Marcel - that's helpful. It would be good if the issues with forum could be resolved so that the two separate sub-fora that already exist for official and beta driver release could be used for each release stream - which I assume was the initial reason for creating them. It seems all releases get dumped into the beta forum which adds to the confusion.

  • Because of this I installed Beta drivers, thanks...

  • MACM BiemansMACM Biemans Member
    edited June 2022

    I can confirm this. Having WRQ issues for some time on my DD2. I'm able to flash any firmware by going into bootstrap mode (hold poweron button for aprox 10 secs). Then power off, connect wheel, power on -> WQR popup.

    I'm lucky to have a spare Clubsport 2.5 so being able to flash my wheels. I have submitted a RMA request for my DD2 to be repaired / exchanged.

    Edit: I'm having this WRQ issue for some time already. The weird thing is, it used to work so now and then. I've always been thinking it was a driver issue, but now I'm convinced it's hardware. Updating/flashing works flawless on the CS 2.5

  • Starting the Device Module Bootloader just crashes and the base gets turned "off":

    There's a window that says "Press any key to continue". The Firmware updater window is up for two seconds or so. The screen of the base turns black, and nothing happens.

This discussion has been closed.