Fanatec Driver 442 (Beta) for CSL, CSW and Podium WB (all wheels)



  • I'm assuming you mean when I plug in the hub without the USBC BME plugged in does anything happen/recognized on the Fanatec Control panel? If this is what you mean, nothing happens to the control panel when the wheel is mounted, BME plugged in or not. So does that mean the hub is the issue? Any fixes? I'm a month in on a brand new product I still can't use it or get a timely helpful response from CS. Thank you.

  • Josh LawsonJosh Lawson Member
    edited July 2022

    I would like to add, I just rolled back drivers to 356, WB 670, Motor 38 and when I insert the PHUB (whether the BME is connected or not) the display on the base flashes 3 times maybe 1 second between for a 1/2 second I see Attention: torque enable? and the steering wheel flash and everything stops and the base requires a restart before I can again use my F1 wheel and everything works as designed. I'm never able to see PHUB or BME on the control panel. See video above.

  • Hi Marcel, I think I'm experiencing something similar with my DD1 but it's on ACC and AC, and I don't know if it's software or hardware related. It's a replacement wheelbase I received in April under warranty.

    It feels like the FFB is changing while I drive on ACC. Sometimes it feels like there is more damper and the wheel is smoother/heavier. Other times it feels like the damper effect isn't there and the FFB has more of a springy feel to it. I usually get these switches in FFB feel after a crash, but it does sometimes happen after a high speed/load corner as well. In AC, sometimes when I load into a track and get driving it feels like the damper effect is missing again. I can usually fix this by restarting the game but sometimes it takes multiple restarts.

    I was on driver 439 until I updated to 442 and it does feel like it's improved with the new driver but the issue is still there. It's more subtle with the newer driver but still noticeable.

    Is there any way I can log what the FFB is doing? I'm hoping to understand if this is something I need to reach out to support for or if it's driver/software related.

  • I think i have caught up on the issue, or at least its fixed but don't have the time to pin point it down. ( check the first quote for reference ).

    The changes i made:

    • Went with 1440 degrees instead of Auto
    • Enable Telemetry in the last Fanalab tab for rF2
    • Enable LED/Hardware Support for rF2

    Not sure which either of this fixed the issue, but its not present neither on 439 nor 442 atm (442 ffb is so numb and muddy is completely no go for me). Tbh if its from the telemetry/hardware support of fanalab needing the feed from the game and you guys haven't caught this up, dunno what to say than disappointment. I was ready to give up on the DD and switch to other company, i'm kinda even still are. Looking at forums and reddit the amount of people dumping the DD1/2s for poor FFB, could be one of this reasons. You guys really need to make it clear that you need to use fanalab and to use it properly, like this to be the first message on the board and fanalab coming with each firmware package........

    Yet to test if there is a change in AC, but at least for me rF is bench for FFB, it's quite showing whats up.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Yes, then the BME is not the issue and it's likely to be the Hub especially if the base is otherwise working normally with other wheels but it can theoretically also be caused by the base not communicating correctly with the wheel. Sadly this can only be figured out by customer support and I hope they can help you soon and resolve the issue.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Here the F1 wheel was connected right? It could be that the base has an unreliable communication with the wheel and that its somewhat working with the F1 wheel but has some interruptions and the PHUB maybe has a bigger problem.

    The recovery tool for steering wheels I've previously shared didn't help right? I'll send you something via PM but I think if the previously suggestions didn't help then they also won't

  • Marcel PfisterMarcel Pfister Member, Administrator

    There is log function available for you which could help finding the issue.

    Do you use the new constant damper which ACC offers?

    If it happens the next time you could try to adjust the DPR setting between 100 and OFF to see if the behavior changes. If yes then there seems to be a damper effect "stuck" and not cancelled. 442 should have improved on that but I've heard from some that its not completely fixed yet and we will take another look at it.

  • Hello @ all,

    got a DD Pro 180 with a McLaren Gt3 v2 and a universal hub. I am on 440 and my updateManager told me that there is an update for the wheel and the hub. But when I try to update both wheels, there are ended up in an updateLoop. Can´t get them out of the loop, reinstalled 440 but cant get them to work anymore :/

  • edited July 2022

    tried now to go back to 439 but with the same result :( I start the ControlPanel and the FirmwareManager told me that there is an update for my McLaren Gt3 v2 (v44) when I start the update the update went fine till 100% but then the whell did a restart and hangs in debugMode (where the leds are flashing in different colors) and it hangs in that position...

  • Hi, a couple of days ago I installed the 440 driver and updated all my wheels with new firmware, and it seems there is a bug in the Multi Position Switch (MPS) on my McLaren GT3 v1 wheel. Even if I select PULSE it acts like ENC (encoder) in Assetto Corsa Competizione. PULSE is the only thing that works in that game for me.

    When using PULSE it normally sends a signal when the switch is moved to a different position, giving 12 different input values in ACC.

    But now, even when using PULSE, it only gives two values, one when I move the switch clockwise and another when I move it counter-clockwise.


    Wheel base: 690

    Wheel base motor: 22

    Steering wheel: 34

    Last driver was (probably) 429.

    I can't remember what firmwares were installed then, sorry.

  • I fixed my problem in "repairing" the instalation with the driver installer. Anyway, thanks for helping ;)

  • Hmmm, I could swear I have always used PULSE and that that has worked fine. I tried CONST just now and I get some odd behaviour. When I have TC set like in the attached image these are the values I get when rotating the MPS (position 0 is the leftmost position and position 11 is the rightmost position):

    Rotating clockwise starting from position 0:

    0 - TC 1/11

    1 - TC OFF

    2 - TC 1/11

    3 - TC 2/11

    4 - TC 3/11

    5 - TC 4/11

    6 - TC 5/11

    7 - TC 6/11

    8 - TC 7/11

    9 - TC 8/11

    10 - TC 9/11

    11 - TC 10/11

    Rotating counter-clockwise starting from position 11:

    11 - TC 10/11

    10 - TC 11/11

    9 - TC 10/11

    8 - TC 9/11

    7 - TC 8/11

    6 - TC 7/11

    5 - TC 6/11

    4 - TC 5/11

    3 - TC 4/11

    2 - TC 3/11

    1 - TC 2/11

    0 - TC 1/11

    So as you can see I get different input values depending which way I turn. It's just not behaving correctly. It's the same for ABS.

  • edited July 2022

    You have the positions set to the wrong inputs and you also have to also use them as "Extended Input" with 0.5s delay, only then they work correctly.

    Has to look like this:

  • May someone please PM me the 442 driver.

    I received my DD1 in mid June, and so I have only been able to use the latest driver, 439.

    Is this driver suspected to go live with the next Fanalab update?

    Thanks in advance!


  • You need to wait for the next Driver 443 (or use 442 at your own risk if you find someone who sends it to you).

  • Trygve ThomTrygve Thom Member
    edited July 2022

    Well how about that! You learn something new every day :D

    Thanks a lot, it works just fine now!

    You wouldn't happen to know how to get the MPS to work in AMS2 as well, would you? ;-)

  • I'm using Maurice's FanaLab profiles as well as his suggested in-game settings. The profile has DPR set to 50 and I did change it to 0 a couple of days ago when I saw that recommendation on the forum, but it still has the same behavior unfortunately.

    I'll try the logging function and report back.

  • No, the F1 wheel always works. The 911 wheel with PHUB and BME is installed, not recognized and this is the behavior seen. Since it occurs with the BME disconnected I agree it’s likely related to the PHUB. Question is, is there anything I can do to rollback the firmware in this in situation as it started with a firmware update? I’m trying to get help for almost a month now via CS.

  • I have jump/jolts with my DD2, specifically in iracing and once I change my steering rotation and would like to test the new fw if that is still an open offer.

  • Hugo VranicHugo Vranic Member
    edited July 2022

    I installed 442, updated everything, had to re-install Windows, and then could only install 439. Now neither Fanalab nor the Fanatec mobile app works. Is it the driver mismatch, or should I troubleshoot elsewhere?

    I've tried different Fanalab versions, both the latest and the one meant for 439.

    (GT DD Pro)

  • I've commented a couple times but I'm guessing you haven't seen them. Does this offer still stand to test? I have a DD2 with PBME and have jumps/jolts, specifically in iracing and when I change my rotation settings. If not then its no big deal, but if you still want to test it then I would like to test it. Thanks.

  • edited July 2022

    Those that feel they are capable of installing the revoked driver should be capable of finding it on the internet.

    But don’t blame Fanatec if anything goes wrong.

    peraonally I’m waiting for the official 443 driver.

  • You should add that everyone who is doing that makes it on their own risk. If there is an issue with updating and the device gets bricked, I dont know if the warranty will be valid in such a case as the driver is officially taken down for a good reason...

  • Sure enough, it's quite easy to find external download links from review/niche websites who haven't (or maybe won't) update their v442 driver announcement pages. Given the nature of the "bricking", and the install procedure instructions, I will attempt an update regardless of the risk and report back in short order. For posterity, people, please don't do what I'm about to do. It definitely goes against Fanatec's wishes and creates a massive risk of device destruction. I am an a-hole, and risky/adventurous enough to jump off that cliff just to see if I hit the water. Don't be me. And for those still reading, you'll see that this update doesn't even benefit me much at all. I'm just doing it out of curiosity.

    My decision will be:

    Update CSL E v1.1 wheelbase, then

    Update Formula V2 wheel, then

    Update CSP v3 pedal,

    one at a time.

    If people can't read and follow simple instructions it really isn't Fanatec's fault, IMHO. There's always been a disclaimer/problems with device corruption on driver updates. Even with the WARNING disclaimers during pedal update, the known port burnout from having both USB and RJ-45 cables connected on the pedals hasn't stopped people from making that very mistake.

    Regards, Craig M.

  • I'm not asking for driver 442. As quoted on my post, Marcel says that there's a working version of 443 that is close to being done and are testing with people who want to test it, that is what I'm asking about.

  • Been using this firmware update for a while. Played AMS2 just fine, finally tried ACC with it and didn't get a lap before the buttons on my 2019 formula wheel stopped working. So i exited the game, turned off the wheel base and turned it back on and now it is stuck in some wireless quick release firmware update screen. The wheel base turns on, rotates to the right, centers and then the firmware update pops up. I honestly have less than 200 hours on this DD1. I don't know if ACC broke it or this firmware. I tried booting it without the wheel and same issue. Any suggestions? Thanks

  • You have to contact the support. WQR issues can not be fixed by the customer, it's a hardware issue which needs a repair or even a full exchange of the whole base.

This discussion has been closed.