CSL Elite LoadCell Pedals do not work

A quick history:

I use a DD Pro Base with the CSL Elite Steering wheel McLaren GT3 V2 and the matching CSL pedals, so far without LC. Everything worked great on a Playstation 5.

I bought an LC kit privately months ago, which unfortunately didn't work. Now I had decided to buy a new LC set from Fanatec, unfortunately with the same result.

I can connect it to the PC via USB, it is also displayed correctly, so it would probably work.

When connecting via RJ12 cable, I no longer get any feedback on the PC.

I have tried many things, updates, downgrades and searched all the forums for hours. Without success.

Now I wanted to reinstall everything so that I could at least drive without LC. But unfortunately I no longer get a signal from the standard brake. Even if I connect it as a clutch with LC to the PC, I no longer get a signal in the display. Sometimes, however, the signal flickers.

This means that I can no longer drive at all.

I know that these problems occur more frequently and that I am not the only one with them. Is there perhaps a solution to the problem in the meantime? Does anyone have any ideas?

Fanatec support has been contacted, but it will probably take some time.

Many thanks in advance!


  • You might try changing the calibration of the pedals as I recall one person having a similar issue and fixing it by toggling between Auto and Manual calibrations that brought the pedals back to life, I don't know what other procedure he followed though.

    1) In Fanatec config panel for the pedals, try changing the calibration method to Manual and set the min and max as normal (Even If the pedals aren't showing any input signal).

    2) Next change the calibration method back to "Auto" and set the Max threshold by holding the required pedal for longer than 2 seconds in that position.

    3) If all that doesn't work, try a few times the whole process again.


  • Cezary LeśnyCezary Leśny Member
    edited July 11

    I have literally the same issue. I've reported it to Fanatec and there's no response for weeks. Above steps doesn't work because I don't even see the calibration menu when connected to base by rj12. Link to my post: https://forum.fanatec.com/discussion/31273/csl-pedals-with-loadcell-issue#latest

Sign In or Register to comment.