Any idea why the Quick Release of DD+ fail during the firmware update ?

Firmware Manager says me there is an new firmware for the QR (v40 to v47), but fail during the update.

The base DD+ is up to date.



  • The problem is the wheel is already detached.

  • If everything works, don't update, and wait for the next release.

    There's really no need to update the firmware for now, just wait for Fanatec customer service to return to normal. If you ever have an unsolvable problem, you will be without your DD+ for weeks waiting for a response from Fanatec.

  • weeks is even a good, you may end wait even longer, like shipment process and so on.

    for me it would take a week for send and another week get that back only because off shipment self

  • Hi,

    I had the same issue with my DD+

    I just closed the window and repeated it. I had the wheel off during the update and updated the wheel afterwards.

  • Can you describe what you did exactly please? I have the same problem with my DD+

  • I'm having the exact same issue. Not able to successfully install the firmware update for the quick release. :(

  • MadDog-ICMadDog-IC Member
    edited February 16

    Try forcing a manual Firmware update of the WQR 3 to 5 times.

    1) Have the Base and Motor FW all updated and steering Wheel removed before doing this.

    Don't try to load any Hex files in the next step, it is defaulted to the right one from the "Fanatec Driver" version loaded, even though it looks like it hasn't.

    2) Tick the "Manual Firmware Update" box at the top of the Update manager and then select the "Manually Update Quick Release" button -> Then click the "Flash Button". If it fails (Depends on error) rinse and repeat, keep trying a few times as it may eventually work, If it doesn't work in may be that your base has to be RMA to Fanatec due to a faulty WQR.

    Do you get the same error as the other users above picture.

  • Can you please elaborate on how to manual firmware update? I am having tons of issues updating both the base and the qr2 firmware using my PC 455 driver.

  • I was getting the same error as the other users above. Tried 3 or 4 times yesterday, failed every time. Tried today and it worked the first time. I waited to turn on the DD+ base until my PC was fully booted, and I removed the wheel before turning the base on. Hit update in the firmware manager and it updated successfully. 👍️

  • MadDog-ICMadDog-IC Member
    edited February 17

    My previous post was exactly how to do manual FW updates (Unfortunately I am not sure you can force a manual update of the WQR as I have never had to do it, and looking at it today it doesn't offer me a button to do it).

    Hard to help without having any information on what errors screens you are experiencing with your specific issues.

    1) Need snapshot of "Fanatec Control panel" showing current versions of Driver and FW revisions.

    2) Need snapshot of all Fanatec log files and post here in forum: Fanatec Control Panel Menu -> Settings Menu -> Collect Log Files button.

    3) Photos of any error screens that you get whilst trying to do updates.

    *** Screen shots can be taken with Windows 10 using snipets hotkey: "Windows Key + Shift + S" and then saved to upload here. ***

    (*** Do this at your own risk, as it can make your Wheelbase unusable if done incorrectly ***)

    (*** Update the Motor first then the Wheel base or you will brick your wheel base making it unusable ***).

    4) Firmware Update Menu -> Open Update Manager Menu

    -> Tick box: [X] Manual Firmware Update / Device Recovery

    -> Click: Manual Motor Firmware Update Button

    -> Click: Manual Wheel Base Firmware Update Button.

    -> Click: Manual WQR Firmware Update Button. (*** If it becomes available ***).

    (*** If any of these proceedures fail, particulary the WQR, keep trying 5-10 times at different times even, each day with fresh start up of computer, etc. ***).

Sign In or Register to comment.