FanaLab 1.64.5 - Post your Feedback here



  • Is this just an iracing thing or are the actual cars programmed like that. I know most race cars you customize the LED's to whatever the driver prefers.

  • Danny IllsleyDanny Illsley Member
    edited June 2022

    Hello all. I am new to fanatec and all this driver update etc, I am having the same issue with the Fanalab not working and the error I get is the same as posted earlier in this thread.

    I hear an XML folder is a fix for some, sorry I am not very technical, what do I need to do in order to put an additional XML folder.

    ** FIXED** Perfect, done the below and all has worked for me.

  • That's not needed anynore.

    Just download the hotfix Fanalab.exe file and replace it in the Directory where you installed Fanalab.

  • Fanalab Last and Best Laptime Not Updating

    • List which hardware, driver and firmware you are using DD1 + latest 442. Fanalab runs fine, hot fix not required. Game profile saved.
    • F1 2021 Time Trial Baku Merc
    • Is it happening with just one game (which one) or all you tried. Not sure yet.
    • Go into detail how we can reproduce the issue. ITM display 4 selected and saved in profile. Displays on LED screen correctly. But Last and Best lap times don't update.
  • edited June 2022

    @Gagaryn and others who experience freezes of the BME:

    Are your freezes by chance looking like this?

    So on one page the values (in this case Gear at n and Speed at 212 on page 1) are frozen and when going to a different page the values are working again and when then coming back to page 1 the values are frozen again (in this case Gear at 7 and speed at 136 together now with Current Laptime of 01:27.9)?

    Or are your freezes different and for example even the LEDs or Buttons would not work anymore (which they do in my video above)?

  • When my PBME freezes the complete device stops functioning - no buttons work and the LED's and display stays exactly where it was when the freeze occurred. Paddles and steering still work though. Unplugging and replugging the PBME USB doesn't reset it - It needs either a shutdown and restart of Fanalab or removal and replacement of the wheel.

  • edited June 2022

    Okay that's a totally different kind of freeze then which I never ever experienced yet. I only very rarely get the values freezing of the above video but never a completely freeze of the whole device.

    Will further try over the weekend in AMS2 if I can somehow get a whole device freeze (for the first time ever) but for me I would not rule out that this might be a possible hardware issue or a bad connection at some point between the base and the wheel...

    But I know the value Freezes are currently under investigation, mayyyybe there is a Chance that the whole device freeze you get is fixed with the same fix... But (at least for now) I wont be able to verify this as I dont have that issue at all.

  • edited June 2022


    The latest version of Fanalabs I can use is 1.54.x. With all newer versions my Tuning menu disappears. Today I give it a new shot, but still not working with newer versions than 1.54.x.

    I post some screenshots so you can see what i'm talking about. In the Tuning menu there isn't much to tune.

    I really appreciate your work. I'm hoping to enjoy newer versions than 1.54.x too.

    In the windows property page it shows the Tuning menu just fine, also works fine.

  • edited June 2022

    Your Tuning Menu disappears with every newer FanaLab version because your driver is old and outdated and not compatible with the newer Fanalab versions where the Tuning Menu is then not available because FanaLab cant "see" the base because the old driver and firmware does not send the required new data from the newer drivers and Firmwares as with newer drivers a completely re-structured new Tuning Menu v2 was introduced and implemented into new Fanalab versions so the old Tuning Menu of the old driver 402 you use is not compatible and therefore not shown in Fanalab anymore.

    So all you need to do to get any newer version than 1.54.x running is (finally) updating your driver.

    For this latest FanaLab Version 1.64.5 you need driver 442 which was taken down because of update issues.

    For the older FanaLab Version 1.63 and 1.63.6 you need driver 439 or 440.

  • Hi Maurice,

    Thanks a lot. I checked it frequently in the driver, it just said "Up to date" after i pushed the check for updates button. A bit weird, but i updated it manually. Thanks a lot for your effort.

  • What you checked in the old driver was just if your firmwares are up-to-date with the ones included in that driver.

    The old driver was not smart and had no Internet connection so it did not searched for new Driver versions online.

    The newest driver can do that so it's really impossible to unintentionally have an old driver installed as you get Windows messages and a green warning message directly in the Driver when a new driver is available. But all this was not the case in the old driver 402.

  • Hello @ all,

    My FanaLab app wont start on win11. When I try to start FanaLab the Fanatec splashscreen come up and nothing happens, the FanaLab app wont start on my windows 11 system. With the Fanatec Control Panel I dont have any probelm...

  • edited June 2022

    See first post for a Hotfix exe file which you need to replace which fixes exactly that issue.

  • Just wanted to post that I have same vibration being stuck on issue with driver 442 and this version of Ganalab.

    DD1 Formula Black rim

  • Loukas ZonasLoukas Zonas Member
    edited June 2022

    doesn telemtry ITM works with csl elite ps4 ?

    or it is for direct drive wheels ?

  • The CSL Elite Base does not have a Display where it could show the ITM...

    It is Podium DD and Podium Button Module Endurance exclusive as only those devices have the big screen to show the ITM.

  • Then you should also stay on FanaLab 1.63.6 until 442 gets officially released.

  • Sooo... is 442 an official driver or not? Because previously you stated that it is:

    But now you seem to be indicating that it isn't.

    This is a problem that I've had with Fanatec from day 1... it's never clear what is "official" and what's "beta", and in terms of the prerelease testing by developers, it doesn't seem like the distinction makes much difference. It always feels like a case of "install at your own risk".

  • edited June 2022

    It was but it was taken offline "to prevent further cases of problems with upgrading firmware."

    Will be released again when "several measures to prevent an update being possible in an incorrect order as well as clearer instructions on how to perform the update/downgrade correctly including guidance on how to recover a product from a state where it can't get detected anymore" was implemented.

  • Can we please get an option in Fanalab to individually map an analog clutch axis to become an additional digital game controller button? For instance, I'd love to map the left clutch on my Podium APM to push-to-talk in Discord.

  • Not possible with FanaLab.

    If at all then such a thing needs to be implemented into the driver and firmware.

  • Exact same events for me with combo CSL DD+PBME.

    Happening ONLY in AMS2 when fanalab is running, so hardware issue should probably be excluded.

  • edited June 2022

    Could still be.

    As you can read from previous posts there are others who play AMS2 a lot and dont have this issue.

    I for example drove AMS2 now 9 hours during the weekend with BME and FanaLab running and I only got the value Freezes but never a full complete BME device freeze. A device freeze more indicates to a possible Driver/Firmware or hardware issue (or a bad connection of BME to the Hub Or the Hub to the Base)...

  • That would be a question for the driver Feedback thread...😅

    But AFAIK that's not planned so nothing for anytime soon, if at all.

  • Perhaps the wrong section for this but it has only started when I updated to latest Fanalabs.

    On Iracing testing merc AMG GT3 2020 when I run off track and hit a wall the feel of the wheel completely changes after, like it is heavy and grindy- this hapopoenes even though going back to the pits shows no damage to be repaired.

    Happenes only when hitting walls, other cars hitting me dont do it.

    I am on DD2/FV2 latest drivers, and it only started when I updated to latest Fanalabs. I have top exit the Sim to be able to restore the correct wheel feel - chanign profiles doesnt work.

    Any ideas?

  • edited June 2022

    Are you using driver 442 with Firmware

    That was an issue where the game has activated the DPR channel for no reason on a big Crash into a Wall in previous firmwares but there were some measures taken place with latest firmware to prevent this game issue. To not get the issue with previous firmwares, simply set DPR to OFF.

    But this issue was/is completely independend of FanaLab.

  • Paul HartlPaul Hartl Member
    edited June 2022

    Same as Gagaryn for me too Maurice but I have to turn my wheelbase off and then restart it. Only happens in AMS2, all other sims are fine.

  • edited June 2022

    Same response as I gave him.

    A full device freeze is more likely to be a driver/firmware issue or a bad connection between the BME and the Hub or between the Hub and the Base, especially when only a few people have the issue and the majority does not have that issue at all.

  • You should pull a poll on this subject, you'll probably be surprised by the results 😉. I saddly haven't seen many post saying that BME perfectly works with AMS2 but plenty with freezes reports.

    By following your different answers, what would be your recommandations ? Returning the product by explaining Fanatec services that this is happpening only on a specific game ? I'm a bit confused

This discussion has been closed.